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This manual is intended for  

users that would like to understand the structure  

and advanced solutions of the race result 11 software 

in order to be able to create better solutions for special kinds of events. 

 

This manual is not needed when using race result 11 for standard events. 
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1. INTRODUCTION 
Managing and scoring a complex race is based on three pillars:  

 Managing and calculating the race data. The race scoring software needs to make a lot of 
calculations, like calculating interim times or lap times, calculating ranks, calculating team results, etc. 

 Providing this data to different systems and devices 
 Presenting this data in an appropriate from, e.g. as a result list, as a race certificate, as text message 

to the athlete’s cell phone, etc. 

In chapter 2 you will get to know the structure of the system which will help you understand how data will be 
exchanged between different devices and components. 

Chapters 3 and 4 are very important and will explain the race result data structure and teach you how to 
calculate the information you need. 

Chapter 5 will then introduce different options to present the data in the appropriate format. 

Chapter 6 will be a helpful practical guide how to set up your event with a lot of tips and tricks that make your 
work easier. 

If chapters 3 and 4 were not enough for you, chapter 7 will introduce additional data fields and functions not 
covered before, and chapter 8 will provide answers to frequently asked advanced questions. 



race result 11: Advanced Users Guide 
 

 

6 race result AG | Haid-und-Neu-Straße 7 | 76131 Karlsruhe | Germany

2. SYSTEM STRUCTURE 

2.1. Working Online and Offline 

race result 11 has a server/client based structure that runs both online and offline. Working online means that 
your race data is stored in the Internet on a race result server and can be accessed from any place with an 
Internet connection. When working offline, your race data is stored locally on your computer and can be 
accessed only on that computer and other computers in the local network. Usually, you would work online 
before and after the event which allows easy online collaboration with other members of the team and also 
using the results and registration platform my.raceresult.com. During the event, however, it is recommended to 
work offline so that you still have access to your data even if you lose Internet connectivity. 

2.2. Browser and Windows Based 

Most parts of race result 11 are running in the Internet browser. You would simply log in on 
www.raceresult.com and access your events. Some parts, however, are Windows based programs, for 
example the Transponder Module which creates the connection between your event file and your timing 
system.  

When working offline, the small program race result Web Server runs as your local web server: 

 

 

You still access the data through the browser via a http://localhost/.. address: 

 

Also all other computers in your local network can access the event by entering the IP address of local server 
in the browser, e.g. http://192.168.1.100 
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The Windows based program can work with event files stored both offline and online. In order to open a file 
stored online, select File -> Connect to Sports Event Server: 

 

Then, make sure SportEventServer.com is entered as server and click the Connect button. 

 

Then enter your customer id and password and choose your event. 

 

In order to open an offline file, click File -> Open Event as usual and select the file on your computer. 

You can also open a file in your local network (if the computer is not the local server) by using File -> Connect 
to Sports Event Server and enter the IP address of the local server. 

2.3. Sports Event Server 

The SportsEventServer is the program in the background doing all the data processing. You can access it 
through the icon in the tray bar: 
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In detail, the SportsEventServer (SES) does the following: 

 As the local server, the SES manages TCP/IP connections to the various programs on various 
computers in your local network. 

 It accepts job request from these programs. A job can either be a write job (change participant data, 
add a time, change a setting, etc.) or a read job (retrieving settings, performing a data query, etc.). The 
server prioritizes the job request and processes them. 

 At all times, the server ensures data consistency: it always knows which information needs to be 
calculated or updated. 

2.4. Online Forwarding 

Using the Online Forwarding is an easy way to provide live results on my.raceresult.com when working offline. 
If you have an (even unreliable) Internet connection, the SES will forward all write jobs to the SES in the 
Internet, so that both servers (the local server and the server in the Internet) will do the same and thus have 
the same data status.  

If your Internet connection breaks down, the online forwarding stops, but you still have access to all your data 
and can simply restart the online forwarding when your connection recovered. 

2.5. my.raceresult.com 

my.raceresult.com is an Internet platform to provide online registration and results to your participants. It is 
connected directly to your event file, i.e. whenever you change something in the file, the changes will be 
reflected on my.raceresult.com (almost) immediately. You only have to decide which information you would like 
to publish on the platform and you will not have to update the information ever. 
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3. DATA STRUCTURE AND DATA PROCESSING 
Now we are starting with the advanced parts. Remember that race result 11 separates the calculation of data 
and the presentation of data. This and the next chapter only explain how to set up your event so that the 
system makes exactly the calculations you need. The presentation layer will be explained later in chapter 5. 

So, in order to understand race result 11, you have to understand first how it handles data. Two aspects of 
handling data have to be separated: making necessary data available (calculation) and retrieving data 
(filtering, selecting fields, sorting). Assume that you would like to create a list of the three riders that have been 
fastest in the second lap. First you will set up your event so that it calculates the rank in the second lap. From 
then on, this information (rank in second lap) is available for all participants. You can use this information like 
any other field (e.g. year of birth), but the system will make sure that it is always up-to-date even if the 
underlying results may change. This field can then be used to retrieve the required data, for example: 

 Fields: rank_in_2nd_lap, bib, name, time_in_2nd_lap;  
 Filter: [rank_in_2nd_lap]<=3 
 Records ordered by rank_in_2nd_lap 

This also means that the data retrieval is based on the participants, but the participants’ data can have 
different sources: 

 Stored data fields e.g. bib number, last name, date of birth 
 Assigned fields e.g. name or length of the assigned contest, name of the event, date of the 

 event, age group name 
 Derived fields e.g. age (derived from date of birth and event date) 
 Stored times e.g. time stamp when passing the 10K split timing point 
 Calculated times e.g. time needed from half marathon split to marathon finish.  
 Formatted times the time stamp 5 minutes and 3 seconds can be presented in many formats, e.g. 

 05:03, 00:05:30.0, etc. 
 Calculated ranks e.g. rank in second lap, or: finish time rank of all athletes having the same first 

 name (hypothetically) 
 Calculated team results, e.g. team rank, team time 

If you know data bases, you can think of a query over the table participants joined with other tables (event 
data, contest data, age groups) and some other magic that makes sure that you also have immediate access to 
all calculated values such as ranks. 

Whenever you set up an event, you need to think about, first, which information you would like to store besides 
the standards fields (e.g. participation in city championship, t-shirt size, etc.) and which information you would  
like to calculate: which times/points/values are needed? Which ranks are needed for my reports and 
certificates? Which team results are needed? Start to set up the scorings settings in Main Window -> 
Advanced Settings accordingly (this chapter) and then set up the reports you need (chapter 5).  

In the following, the data sources listed above will be described in detail. 

3.1. Stored Data Fields 

The stored data fields are pretty straight forward. You enter something and when using the field it will show 
what you have entered. When creating reports, you can easily select the desired data field in the field wizard: 
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Besides the standard fields like bib, name, club, etc., the 20 additional text fields (ATF), the 20 additional yes/no 
fields (AYN) and the 20 additional yes/no text fields (AYNTF) serve to save any kind of additional information. 
Note that you can access these additional fields either by its name (e.g. ATF5) or by the label you defined (e.g. 
TShirt). The second option is nice, because you do not have to remember the number of the field, and even if 
you change the numbering, you do not have to update your reports. In return, you cannot change the label 
without changing your report. 

Note that there are also stored fields that cannot be written in externally, e.g. Created and Modified (when the 
record has been created / modified). 

3.2. Assigned Fields 

Depending on the contest / age group / nation / country assigned to a participant, you also have access to the 
other attributes of the selected contest / age group / nation. 

You can access the attributes of the assigned contest / age group / country also simply by selecting them in 
the field wizard: 

 

It works the same with the attributes of the event (of course it is the same event for every participant): 

 

A simple use case for that is a race certificate: instead of putting the event date on the certificate as fixed text, 
better use the field EventDate so that you do not need to update the certificate next year. 

Maybe you are wondering what attributes the assigned country / nation has: these are different 
representations of the name of the country. If you select Germany as country for a participant, you can show it 
on a list / certificate as Germany, GER, DE, or Deutschland. 
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3.3. Derived Fields 

Derived fields can be used like any other data field, but they are derived from other fields of the participant, e.g. 

Age:  Derived from date for birth and event date 

Year:  year of birth (e.g. 1983), derived from date of birth 

Year2:  two digit year of birth (e.g. 83), derived from date of birth 

LastFirstName:  Combines last and first name to (e.g.) Doe, John 

3.4. Stored Times 

For each participant, an arbitrary number of times can be saved, but you need to define these Results first in 
Main Window -> Results. For example, you define that each participant can have the stored times Start, 10k 
split, half marathon split, 30K split, 40K split, finish by setting up these results accordingly. 

Note that a time is no more than a decimal number that usually represents the time in seconds. So a time of 30 
minutes would be stored as the value 1800 (seconds). Not necessarily, the value stored has to be a time, it can 
also present points or any other value that is a number. 

To access these stored values, you can use the field DecimalTimeX (replace X, e.g. DecimalTime5 for the value 
in the result with ID 5). There also is a short version Tx, e.g. T5.  

Usually, this short version would be used to calculate formula results (see below), for example using a formula 
like T5-T4, whereas on reports and certificates you would use the formatted times (0:30:00 instead of 1800). 

3.5. Rounded and Formatted Times 

The rounded and formatted times are derived from the stored (decimal) times. The rounded times can be 
accessed via the fields RoundedTimeX or short TRx (replace X, e.g. RoundedTime5 or TR5). If you are showing 
rounded times on reports, it is recommended to make calculations using rounded times as well, otherwise 
rounding discrepancies may occur. 

The rounded times are also the basis for the formatted times. The system uses the rounded value to build a 
time string like 1:23:45.67. This formatted time can be accessed using the fields TimeX (e.g. Time5). 

All fields can simply be selected in the field wizard: 
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In this list you can see that you can also access the formatted time via the name, e.g. 10K_Split. It has the same 
advantages and disadvantages like in case of the additional text fields: when you change the ID, you do not 
have to change your reports, but when you change the name, you have to. 

The screenshot also shows that each result has two more fields: InfoTextX is a text field that usually contains 
additional information from the timing system (e.g. hits, signal strength, etc.), and TimePositiveX is a derived 
field which is 1 if the time value is greater zero, and 0 otherwise. 

Also note that for rounding and formatting times, the settings from Main Window -> Results will be used. If a 
rounding / a time format is not specified there, the rounding / time format from the assigned contest will be 
used. This way, you can define a default time format for each contest, and for some results you will define a 
different time format, e.g. “s” for points. 

3.6. Calculated Formula Results 

When defining a formula for a result in Main Window -> Results, no values can be saved in this result, but 
instead the SportsEventServer will automatically calculate the values according to your formula. The formula 
can be any formula that returns a number (since results can only contain numbers). 

The formula assistant (click on the hand symbol) helps you to set up easy formulas and to learn the syntax: 

 

The easiest kind of formulas are difference times. Example: when you save the time stamps after lap 1, 2, 3.. in 
results 11, 12, 13, .. you can set up results with formulas T11-T0, T12-T11, T13-T12, … to calculate the time of lap 
1, 2, 3, … 

Other formulas can build the sum/average/minimum/maximum over several results or look up a value in a table. 
Finally, you can also build completely individual formulas using the expressions and functions described in the 
next chapter. Very often the function iif() will be used. For example the formula  

 iif(T21>0; T21; T22)  



race result 11: Advanced Users Guide 
 

 

 www.raceresult.com 13

will return the value of result 21 if it is greater zero, and the value of result 22 otherwise. 

Many formulas use only times of the athlete, however, you can also access the participant’s data, e.g. 

 iif([Sex]= "f"; T21; T22+10) 

If the participant is female, the formula will return the value of result 21. Otherwise it will return the value of T22 
and add 10 seconds (see next chapter to learn what the formula returns for men who do not have a time in 
result 22). 

The formula can also access the ranks and team scores. Assume you would like to calculate points like this: 1st 
place: 10 points, 2nd place: 9 points, … 10th place: 1 point; others: 0 points. For this you can use this simple 
formula: 

 max(11-[Rank1]; 0) 

The formulas can be nested and thus get as complicated as necessary. You can imagine that you can calculate 
virtually anything, similar like in Excel. 

3.7. Finish Result 

Another important concept regarding results is the Finish Result. The finish result is an attribute of a contest 
and can be defined in Main Window -> Contests. Selecting one result as finish result has the following effects: 

 The field Finished will be 1 if the participant has a positive time in the finish result, i.e. the field 
corresponds to the field TimePositiveX where X is the ID of the finish result.  

 The fields DecimalTime, RoundedTime and Time (without a number at the end) will return the (rounded) 
decimal time value and formatted time of the selected finish result. 

Note that the finish result can refer to different results for participants in different contests. This will turn out to 
be very helpful later. 

By default, also the calculation of ranks is based on the finish result: 

3.8. Ranks 

After defining for example the rank with ID 4, three additional fields can be used: 

 Rank4  the position of the participant according to the rank definition, e.g. 47 
 Rank4p  the position with a period at the end, e.g. 47. 
 MaxRank4 the number of participants in the same group, e.g. 495.  

MaxRank helps to create an output like: 47 of 495 in age group M50. 

Note that defining a rank only provides these additional fields. Creating a report with this rank is a separate 
step and will be explained in chapter 5. 

Ranks can be defined entirely flexibly. Theoretically, you can define a rank that  

 only considers athletes named John,  
 groups them into those who are born in an even year and those who are born in an odd year, 
 and sorts and positions them by the rounded time in lap 2.  
 If the time in lap 2 is not decisive, the participants shall be positioned by the length of their last name. 

Yes, this is a very hypothetical case, but it shows that there are virtually no limits in what you can do. 

The ranks will be defined in Main Window -> Ranks and their settings are based on three main pillars: filter, 
grouping, sorting.  
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Filter: In most cases, you would like to exclude certain participants from the rank, for example those that have 
not finished. These will not receive a rank (more precisely: the rank field will contain the value -1). For the 
standard ranks, the filter is therefore simply Finished (based on the finish result, see above), but the filter can 
be any other expression, e.g. 

 [FirstName]= "John" theoretical example from above 
 [Finished] AND [AYN1] participant needs to have finished and the AYN field needs to be set 
 T5 > 3   the value in result 5 needs to be greater than 5 

Grouping: the fields selected here group those participants fulfilling the filter into several groups. Two 
participants will only be in the same group if they have identical values in all fields. For example, a typical 
gender rank would be grouped by the fields Contest and Sex, so that there are groups like 5K male, 5K female, 
10K male, 10K female. For each of these groups there will be a 1st, 2nd, 3rd, … place. 

Sorting: the sorting can be defined either in the rank definition (turn off option Order According to Contest) or in 
the contest settings (turn on the before mentioned option). The selected order fields define how the 
participants shall be ordered and then ranked. If the first field is not decisive, the second field will be 
considered, and so on. For each field, you can also define if the participants shall be ordered ascending or 
descending. For example for lap races you will need descending: more laps -> better position. 

Finally, there is an option Ties Possible which defines what happens if all sorting fields are not decisive: if the 
option is turned off, the participants will be ranked randomly. If the option is on, two participants will have the 
same rank and then there will be a gap, e.g. 1st, 2nd, 3rd, 3rd, 5th, .. 

The name of the rank is on the one hand helpful to remember what a rank is intended for, on the other hand the 
name can also be used to access the field (same as additional text fields and results). If you name a rank 
OverallRank, you can also access the field OverallRankp which adds a period to the number (note that the 
fields with period return a text whereas the fields without period return a number. In consequence, the fields 
with period cannot be used to sort a list). 

3.9. Team Scores 

Whenever several participants build a team which will be compared with other teams, you need a team score. 
A team score will determine which participants belong to the same team, calculate team results (e.g. sum of 
the participants’ finish times) and rank the teams among other teams. Again, the team score will only provide 
additional data fields (such as team rank, team time, number of team members, etc.) which can be used to 
create appropriate lists, race certificates, etc. 

The team scores can be defined in Main Window -> Team Scores. Note that you can create several team 
scores if needed. 

When setting up the team score proceed in the following steps: 

1. Think about who builds a team. Which fields do team members have in common? In many cases this 
will be Contest and Club – the team members have to have run the same contest and need to be in the 
same club. You can also add the field Sex if teams can have either only women or only men.  
Enter these fields in the Team Aggregation settings. 

2. Define the minimum and maximum number of participants per team and enter these in the Number of 
Participants settings. In many cases, the teams will have a fixed size (e.g. 3 participants per team), so 
make sure to enter the same value for minimum and maximum.  
If a team can have any number of women, make sure to enter 0 for Min. Number of Women. 

3. Use the Filter setting to define who will be considered for the team score. The filter may be 
[Club]<> "" 
so that participants without a club name will be ignored. 

4. What happens if the number of participants of one club is larger than the maximum team size? 
Depending on the option Max. No. of Teams the team score will create several teams for a club or it 
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will associate the other participants of the same club with the team, but they won’t be scored. Think of 
a team score for school classes: all children shall be part of the team, but only the best 5 shall be 
scored (i.e. their finish times will be summed up for the team time). 

5. Think of how the teams will be grouped before the ranking. Enter the appropriate fields in the Grouping 
settings. Usually, this is a subset of the Team Aggregation fields, e.g. only Contest: there will be a 1st, 
2nd, 3rd, .. team for the 5K race and another 1st, 2nd, 3rd, .. team for the 10K race. 
If you added Sex to the Team Aggregation fields you probably want to add it to the Grouping as well. 
Otherwise the male and female teams will be ranked together, for example on the three first ranks 
there may be male teams and a female team may have the 4th rank. 

6. Using the settings in the Results section you can define which times will be used to build the team 
times. Simply, select one or several results and determine if the team time will be the sum, average, 
minimum, maximum or number of times.  
Note, these results also determine how the teams will be ranked. If you select the finish time as Result 
1 and sum these up, the teams will be ranked by the sum of this time, either ascending or descending. 
If result 1 is not decisive, result 2 and then result 3 will be considered. If all results are not decisive, 
two teams can have the same rank if the option Ties possible is activated. 

 
Among others, the team score provides the following new fields: 
TSx.Rank  rank of the team 
TSx.MaxRank  highest rank given within the group. Can be used two show “rank 5 of 23”. 
TSx.Time1  formatted time of the team according to the Result 1 setting 
TSx.DecimalTime1 decimal time of the team according to the Result 1 setting 
TSx.Position All team members will be numbered from 1 to [team size]. This field returns that 

number. The order by which the team members are being numbered depends on the 
Order Participants setting. 

TSx.Number  number of team members of that team. 
TSx.TeamIndex  If several teams can be built from one club, the first one will have team index 1, the 
   second team index 2, and so on. 

3.10. Team Scores with Lap Mode 

The Lap Mode is a special mode of a team score designed for team lap races like 24h races. There is only one 
timing point per lap and only one rider will be on the track at a time. Thus, a lap time may be the time stamp of 
one athlete minus the last timestamp from the previous athlete. 

When activating the Lap Mode in Main Window -> Team Scores, the team score will take all times from the 
team, sort them and calculate the lap times. The team will be scored first by the number of laps and second by 
the time needed. 

The team score will then provide a lot of additional fields: 

 

For further information, refer to the race result Online Help and the template “Team Lap Race”. 
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3.11. Background Information: Real Time Scoring Engine 

On the previous pages you have read that race result 11 can be used to make a lot of complex calculations that 
are almost as flexible as Excel. For a race, it is not only important that you can make any kind of scoring, but 
also that these calculations will be performed very fast with virtually no delay. During the race you may need 
instant real time information without any delay in order to be able to show it on a live screen or even in TV 
graphics. 

For this reason, the SportsEventServer in the background performs almost every calculation in real time, i.e. 
whenever some data is changed (e.g. a new lap time added), the server will recalculate and update all 
depending data (e.g. number of laps, fastest lap, slowest lap, rank of this rider and other riders). Therefore, the 
server analyzes the dependencies in the event file and thus knows which information may need to be updated 
if some data is being changed. The dependency tree may look like this: 

 

In this example, the system understands that the Total Rank depends on the result Finish, which itself depends 
on the result AfterRunning and so on. 

This example is fairly simply. If you think of an event like the Tour de France, you can imagine that an event file 
can have hundredths of results and dozens of ranks with long dependency trees. There are results for each 
day, special sprint scores, overall scores, and so on.  

Real Time Limits 

Note that not everything can be calculated in real time: 

 Team scores will be updated in real time only if the real time option is activated in the settings 
 A formula result will not be calculated in real time if it depends on a rank or a team score. 
 Everything that depends on something that is not being calculated in real time cannot be calculated in 

real time either. 

If something is not being calculated in real time, it will simply be calculated when needed: if you open the 
result list based on a non-real time team score, the system will calculate the team score first before creating 
the list what will create an additional delay of a few milliseconds or seconds depending on the size of the 
event. 

Circular References 

When you  set up a complex race you can quickly make a tiny mistake which creates a circular references. For 
example the definitions A:=B+C+1 and B:=A+1 create a circular reference. If C has been updated, A needs to 
be updated. In return, B needs to be updated and then A needs to be update again. This will create an endless 
loop so that the system would never stop working unless it detects the circular reference. 
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The SportsEventServer detects even long complex circular references and then refuses the calculation since 
something must be wrong in your definition. However, it shows the detection of the circular reference only in 
the log file: 

 

If something is not working as expected, checking for a circular reference may be helpful. 
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4. EXPRESSIONS AND FUNCTIONS 

4.1. Expressions and Functions 

In the last chapter we have already used expressions (called them formulas) without actually understanding 
what they are and how they work. Expressions use some operators and functions on some data to generate 
some new data. For example the expression 

 max(T1; T2) + 1 

uses the data fields T1 and  T2 to generate a new information: the maximum of those two added to 1. 

Operators and functions are actually the same, but operators always have two parameters and their syntax is 
different. The expression 

 T1+T2 

uses the operator “+”, but theoretically it could also be a function like 

 add(T1;T2) [Note that the add  function does not exist in race result!] 

In case of operators, the parameters (called operands) will be left and right of the operator. In case of 
functions, the parameters will be in round brackets after the function name separated by a semicolon. 

You will find a complete list of all operators and functions in the race result Online Help. Here, the most 
important ones shall be discussed: 

4.2. Operators 

= equal (returns true or false) 

> greater than (returns true or false) 

<  less than (returns true or false) 

<= less or equal (returns true or false) 

>= greater or equal (returns true or false) 

<> not equal (returns true or false) 

AND logical And (returns true or false) 

OR logical OR (returns true or false) 

XOR logical XOR (returns true or false) 

+ addition 

- subtraction 

* multiplication 

/ division 

% modulo 

: time operator. The operator will multiply the left operand with 60 and add the result to the right 
operand, i.e. a:b is equivalent to 60*a+b. This special operator makes it possible to write times 
intuitively, e.g.  
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iif(T1>1:29:00; "more than 1 hour 29 minutes"; "less than") 

& concat strings 

The last operator & is very important for lists and certificates. Imagine you would like to show last name, first 
name and nation in brackets on a list. Then, you can use this expression: 

 [LastName] & ", " & [FirstName] & " (" & [NationIOC] & ")" 

In this example you can also see that fields need to be in square brackets when using them in expressions, 
whereas fixed texts will be in double quotes. The only fields that do not have to be in brackets are the decimal 
and rounded fields T1, T2, T3, .. and TR1, TR2, TR3, … This way it is easy and intuitive to create formula results 
like T22-T21 

Note that an operator expression like T12-T11 will only be calculated if both operands (T11 and T12) are 
available. If T12 is NULL (not entered / does not exist), the result of T12-T11 is NULL as well. In some cases, 
however, you may want to make the calculation: assume result 32 can contain a bonus/malus which shall be 
added if entered: T12-T11+T32. If T11 and T12 are available, the formula shall be evaluated, no matter if T32 is 
available or not. For that you can use the nz() function which returns 0 if its parameter is NULL (not available):  

 T12-T11+nz(T32) 

4.3. Functions 

These are the most important functions. Please find a complete list of all available functions in the race result 
Online Help. 

nz(a)   returns 0 if a is NULL, and a otherwise 

max(a;b)  returns the maximum of a and b 

min(a;b)  returns the minimum of a and b 

ucase(a)  converts all characters of a to upper case 

lcase(a)  converts all characters of a to lower case 

left(a; b)  returns the first b characters or a 

right(a; b)  returns the last b characters or a 

iif(a; b; c)  if a is true, b will be returned, c otherwise 

switch(a;b;c;d;..) if a is true, b will be returned; otherwise: if c is true, d will be returned; and so on. 

choose(n; a;b;c;d;..) will return the nth parameter (a if n=1, b if n=2, and so on) 

format(n; s) formats the time of n seconds according to the time format s,  
e.g. format(T5; "mm:ss.k")  

4.4. User Defined Fields 

User defined fields can make your life a lot easier. They are very similar to the derived fields like FirstLastName 
(see above), but they are not defined by the system, but instead by you. They can be defined in Main Window  
-> User Defined Fields/Fct. 

When you need one expression in many different parts of your file, you should define it as user defined field. 
For example, when creating a new event file, a user defined field DisplayName will be created using this 
expression: 

trim([Title] & " " & [Firstname] & " " & [Lastname]) 
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It is the default way to show a name on a result list: on all result lists the name column refers to the user 
defined field DisplayName. The big advantage is that you can change this user defined field and in 
consequence all the result lists will show the name in the new format. You do not need to update every single 
result list. 

4.5. User Defined Functions 

User Defined Functions are very advanced. You can define not only your own derived fields, but also your own 
functions in Main Window -> User Defined Fields/Fct. Assume you would like to change the upper/lower case 
of words, so that the first letter is in upper case and the other letters in lower case. For this you could define 
this function: 

RightCase(x) ucase(left([x];1)) & lcase(mid([x]; 2)) 

You can use the new function like any other function now, e.g. 

RightCase("raCEreSuLt")  will return: Raceresult 

Your functions can also have several parameters. For example we can define the add function: 

add(x;y) [x]+[y] 

The names of the parameters can be defined freely. When using them in the definition of the function, they 
have to be in square brackets. 
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5. PRESENTATION OPTIONS 
By now you should have an idea how to generate most of the data you need for scoring your event. In chapter 
7 we will cover some advanced fields and functions, but for now this should be sufficient. Having the 
necessary data, it is now about bringing it into the right form using lists and certificates. 

We assume that you have already familiarized yourself with lists and certificates. You know that a list serves to 
put many records on one page, whereas a certificate will have one record per page with free placement of 
data, pictures and other elements. You have explored the settings of lists and saw that you define these 
through sorting fields (which can also create group headers), data fields (which define what information 
/columns to show on the list) and filters (which define which records to show on the list). You have also 
checked out the Designer which serves to place and format the elements on your race certificate. 

In this advanced users guide we are now going to cover advanced topics for lists and certificates. 

5.1. Lists 

List Sorting / Grouping 
The settings in the section Grouping/Sorting define how the records on the list will be sorted. If the first field (in 
the first line of the settings) is not decisive, the second sorting field will be considered, and so on. When 
turning on the option Grouping a group header will be inserted every time the value of the field changes. 

  

In this example, there are two groupings: the first for the contest and the second for the age group. Also note 
that the list is sorted first by the field Contest (the ID of the contest) and then grouped by the ContestName. 
This way the contests will be ordered by the contest ID (instead of by the contest name), but the contest name 
will be in the group header.  

Using different fields/expressions for the sorting and grouping is very commonly used. For example consider 
the standard team results: 

 

The group header will show several data points (team rank, club name, team time). As a result the expression 
in the 5th line cannot be used for sorting (as a text it would return this order: 1st, 10th, 11th, …, 2nd, 21st, 22nd, ..), so 
that the field TS1.Rank (team rank) will be used first for sorting. 
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Maybe you are wondering what the three slashes (///) in the group header are used for. This is a small hack 
which creates columns within the group headers: 

 

Note that the Page Break option offers a lot of option to insert page breaks (for PDF output) before a group 
header or to repeat the group header on a new page. 

Also, in the advanced settings (accessible via the double arrow >>) you can define colors for the group header: 

 

The advanced settings also offer dynamic formatting, explained below. 

Multi-Line Lists 
Multi-line lists are an easy way to put more information on a list. One record (participant) can have up to 30 
lines on the list. Therefore, simply select a line greater 1 for a field/column of your list.  



race result 11: Advanced Users Guide 
 

 

 www.raceresult.com 23

 

Maybe you would like to have different column widths for the fields in the different lines like in the screenshot 
above: the lap times in the second and third line have different column positions than the basic information 
above. To do so, you have two options: 

 You can enter the exact column position in the extended field settings (click on the double arrow >>). 
 You can set a column offset. All lines will have the same columns, but for example in the second line 

the field will be moved one or several columns to the right, i.e. the previous column has a greater 
column span. 

By the way, note that the system automatically determines the column widths in your list depending on the 
content (unless you set specific column positions). Therefore, the system first determines the needed width for 
each column. If the page is not wide enough for all the data (for example because there are some very long 
club names), it has to shorten some columns. For this, the system calculates the standard deviation of all 
columns and reduces the width of those columns width the highest standard deviation. This means, that 
columns containing for example a time (all times have the same length) would not be reduced in width as this 
would cut the time in every line. Instead the system will reduce the width of, for example, the club name, so 
that only a few outliers will be cut. 

Dynamic Formatting 
Dynamic formatting is way to format different records differently. You can change the color, background-color 
and font style (bold, italic, underlined). For example, you could print all men in blue, and all women in red. 

Therefore, you need to enter an expression in the extended field settings (double arrow button >>) like this: 

 iif([Sex]= "f"; "C(#FF0000)"; "C(#0000FF)") 

The dynamic formatting can be defined either for the entire line or only for certain columns. For further details 
please read the article in the race result Online Help. 

Entering Complex Filters 
The filter settings for a list offer an easy definition of your filter, for example: 

 

If you need to enter a complex nested filter, the GUI may be tedious. In that case simply enter your filter in the 
first line like this: 

 iif(([Contest]=2 AND T2>5) OR ([Contest]=3 AND T2=5); 1; 0)  =  1 
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Multi-Language Reports 
When publishing a result list on my.raceresult.com you may would like to have for example the column headers 
in different languages. Therefore, you will find a small language box at the end of the label fields where you 
can enter your texts for different languages: 

 

Depending on the language chosen on my.raceresult.com, the accordant text will be shown. If you haven’t 
entered the text in a specific language, the system will show the English version. If an English version is not 
available either, the system will use the language entered first. 

List Background 
The settings in the Page tab can be used to change the layout of your report, for example you can define the 
page size and format, page margins, header and footer texts, header and footer pictures. If this does not fulfill 
all your needs you can also put a certificate in the background of your list, which allows you to position texts 
and pictures freely like this: 

 

This option gives you unlimited flexibility in designing your reports. 

Cover Sheet, Back Sheet 
Similarly, you can put an additional cover sheet at the beginning of your report and an additional back banner 
page at the end of the report. Therefore, set up the page as certificate in the Designer and then select it in the 
page settings of your list. 

Multi Column Reports 
In some cases it can be helpful to split the page into several columns: 
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Simply define the number of columns and the column spacing in the Page settings of your list. 

5.2. Certificates 

Certificates are pretty straightforward: you set them up in the Designer (Tools -> Designer) by placing data 
fields, fixed text fields and pictures on the page. The certificate can either be complete and include the 
background image (for example to publish it online) or it only contains the data fields and will be printed on the 
pre-printed sheets. 

Dynamic Formatting 
Dynamic formatting can be used similar to lists. It can be defined in the top right corner: 

 

Data Dependant Images 
Using data dependent images, you can use different images for different participants on the same certificate. 
Assume you would like to show the flag of the participant’s nationality on the certificate. The flags are saved 
as flag_XXX.jpg where XXX is the name of the country in IOC format. 

Then, add a data dependent image and use this expression: 

 "flag_" & [NationIOC] & ".jpg" 

 

If the pictures do not have the same dimension you may want to turn of the stretch mode and instead scale the 
image maintaining the image ratio (see top right corner of the screenshot). 
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Team Certificates 
Certificates for teams work exactly the same like a normal certificate. Instead of the individual rank and time 
you would show the team’s rank and time. If you would like to show also information of the other team 
members, you can simply enter the field/expression in the top left corner and then select the team score and 
the participant. 

 

For example, to show the last name of the second participant of the team (according to team score 1), the 
system will use the field TS1.P2.Lastname. In the preview, you can see that selecting a team score/participant 
only helps you to set up your certificate, but internally the field name will be used. 

 

Printing Certificates 
The certificates can be accessed and printed in the Participants Window through the Certificates tab: 

 

In most cases, however, you need to print several certificates at once which can be done using a Certificate 
Set in the Output Window: 

Certificate Sets 
A certificate set is simply a set of certificates for certain participants in a certain order and using a specific 
design (certificate). The certificate sets can be accessed in the bottom left corner of the Output Window: 
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When creating a new event file, some standard certificate sets will be set up automatically, for example to 
print the certificates for the first three women and men per contest for the award ceremony. 

Publishing Certificates 
Certificates can be published easily on my.raceresult.com. Therefore, go to the my.raceresult.com settings -> 
Publish -> Certificates and simply check those certificate set you would like to publish.  

Certificate Sets will be used to publish certificates, because this way you can define both, the 
design/certificate you would like to publish and for whom you would like to publish the certificate. Only those 
participants fulfilling the filter in the certificate set will be able to download the certificate from 
my.raceresult.com. 

What Else Certificates Can Do 
Besides certificates, the certificates functionality can be used for many different applications. For example, it 
can be used to show the lap times for a team lap race: 

 

Other options are stickers or labels, or printing on race bibs or envelopes, etc. 
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5.3. Presentations 

The Presenter program (Windows based) gives you extensive possibilities to present results on a screen. This 
can be either a standard result list displayed page by page on a video wall or a special list having only one 
page and showing for example a leader board. 

Page by Page Presentation 
These presentations are straightforward as they are so similar to a normal result list. For example, consider the 
following results from a 7h ski lap race (3 riders per team, one of them on the track at a time, make as many 
laps [mountain up in the lift and down on the ski] as possible in 7 hours): 

 

The presentation is running on a large TV in the team area where the teams can check their positions any time. 
It is going through the list page by page and starting over from the top after the last page. 

Leader Board / Live Presentations 
Leader board presentations can be nice for both, the announcer commenting on the race as well as for a video 
wall. As example consider this leader board: 

 

This event is a multisport event (inline, swim, bike, run) with couples and teams of 4. The presentation shows 
the 4 categories via the Split Screen option of the Presenter. For each category, it only shows the leading 
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teams and refreshes the information every second so that the announcer can see everything in almost real 
time. The lists are standard lists with three lines per record and a filter like Rank>0 AND Rank<=5 

Note that some pictures and some colors can make the presentation look much better: 
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6. RACE SETUP GUIDE 
The best way to learn how to set up complex event files is to learn from examples. That is why we provided 
different examples in the support section on our raceresult.com website. This section will describe some 
general design guide lines that proved to be helpful in the past. 

6.1. Choose IDs wisely 

When you set up results or ranks, choose your IDs wisely. Make sure that IDs are intuitive (e.g. lap 1 in result 
21, lap 2 in result 22, lap 3 in result 23, and so on – instead of lap 1 in result 17). Also make sure to leave gaps in 
our IDs, maybe you would like to add something in between later. 

6.2. Use Field Names 

You can access times/ranks/additional fields via the ID (e.g. Rank3) or via its name (e.g. AgeGroupRank). The 
set up of your lists and certificates will be easier to understand later if you use the names instead of the IDs. 
Therefore, make sure to use a short yet concise name that you will not change later. 

6.3. Use User Defined Fields 

Whenever you need an expression like 

 Choose([TS1.Sex]; "Men"; "Women"; "Coed") 

create a User Defined Field. You will definitely need this expression in several reports/certificates later, so use 
a User Defined Field from the beginning. 

6.4. Finish Result 

It has been proofed helpful using ID 1 for the finish time result. If you do so, you always know that the most 
important time will be in result 1 and thus at the very top, for example in the Results tab of the Participants 
Window. 

Only if you have events with different numbers of laps per contest or with several finish lines at different 
locations, it is very helpful to have several finish results. For example: 

 

In this case, there are three results for up to three detections (11, 12, and 13). The results 21, 22, and 23 
calculate the time per lap, whereas result 1, 2 and 3 calculate the time from the gun start until finishing lap 
1/2/3.  

If, for example, contest 1 has two laps and contest 2 three laps, you can simply select “AfterLap2” as finish 
result for contest 1, and “AfterLap3” as finish result for contest 2. 

Instead of using different finish results, there are the following alternatives: 

a) (bad alternative) Remove results 2 and 3, rename result 1 to “FinishTime” and use the formula 
TMax(11;13)-T0 . This way, the finish time will simply be the time after finishing the last lap what 



race result 11: Advanced Users Guide 
 

 

 www.raceresult.com 31

creates  two problems: First, you have to change the rank settings so that someone with more laps is 
better than someone with less laps. Second, if someone runs an additional lap for fun, he would not 
have the correct finish time. 

b) (good alternative) Remove results 2 and 3, rename result 1 to “FinishTime” and use the formula 
choose([Contest];T12;T13)-T0 . This is exactly what selecting different finish results for each 
contest would do in the background, but you have more options. Assume in contest 2, women run only 
two laps, but men three. Then you could use this formula:  
choose([Contest]; T12; iif([Sex]="f";T12;T13)) - T0 
 

For the beginner, we would recommend to simply select different finish results (complicated enough!), but the 
advanced user may appreciate the additional flexibility of option b). 
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7. ADVANCED DATA FIELDS AND FUNCTIONS 

7.1. Position Fields 

Ranks (chapter 3.8) are a handy concept since they are defined once and can then be used everywhere – on a 
list, in a certificate, in a text message. However, sometimes you may want to create a numbered list quickly 
without creating a rank definition.  

Let’s assume you need a result list of all participants named John. Simply add a filter to the list and use the 
field Position instead of the rank: 

 

Looks good, but it should start at 1 again for the 5K race. For that, you can use the field Position1 which will 
start over at 1 when the highest grouping level changes the value. Position2 would start over at 1 when the first 
or second highest grouping level changes the value. 

7.2. Gap Times 

To show the gap between a participant and the winner or the previous athlete, you can use the two functions 
GapTimeTop() and GapTimePrev(): 

 

The rank defines who the winner / previous rider is (winner overall, winner gender, winner age group). Text 
first defines what to show for the first participant (does not have a faster athlete). The time format parameter 
defines how to format the gap time. 

The expression  

 GapTimeTop(1; 2; "--"; "+mm:ss") 

may have this result: 

 

7.3. Top and Prev Times 

The functions GapTimeTop and GapTimePrev are actually based on the Top and Prev Times: the fields 

 RankXTopY and RankXPrevY 
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return the time in result Y of the winner / the previous athletes according to rank X. So the field Rank2Top1 may 
return the (decimal) time of the first man/woman. If you add an “R” the field will return the rounded value 
(Rank2Top1R / Rank2PRev1R), and if you add the word “Text” the field will return the formatted time 
(Rank2Top1Text / Rank2Prev1Text). 

So, instead of GapTimeTop(1, 2, "--"; "+mm:ss") you could write also: 

 iif([Rank2]=1; "--"; format(TR1-[Rank2Top1R]; "+mm:ss")) 

Frequently, RankXTopY is used in formulas calculating points. For example, the formula 550 - 250 * [Time] / 
[TimeOfFirst] (minimum 0 points) could be implemented in race result like this. 

 max(0; 550-250*TR1/[Rank2Top1R]) 

7.4. Bunch Times 

Bunch times are common in cycling: as long as the gaps between the riders in a field are less than, for 
example, 1 second, all of them receive the time of the first rider in the field. 

There are two ways to do this in race result: one is easy to use but does not run in real time calculation, the 
other does but is more complicated. 

Easy Option 
The field  

 RankXPrevYRepeatedZ  

will return the bunch time of result Y. The previous rider is defined by rank X and the gap between two riders 
needs to be less or equal Z seconds. If you add an “R” the field will return the rounded value, and if you add the 
word “Text” the field will return the formatted time. 

 Rank2Prev1Repeated1Text 

Efficient Option 
In order to calculate the bunch times efficiently, it should be set up as result in Main Window -> Results like 
this: 

 

TPrev(X; Y) also returns the time of the previous rider from result Y. The previous rider is defined by rank X. So 
the time gap to the previous rider is  

 T1-TPrev(2;1) 

If this is less than 2 seconds, the formula takes recursively the bunch time of the previous rider until the gap is 
>= 2 seconds. If the gap is >= 2 seconds, the time from result 1 will be used. 

7.5. Team Scores: Accessing Other Participants 

When creating a race certificate for a team, you can access the data of all members of the team: 



race result 11: Advanced Users Guide 
 

 

34 race result AG | Haid-und-Neu-Straße 7 | 76131 Karlsruhe | Germany

 

As you can see, you can access the data of the yth  member of the team according to team score x via TSx.Py. 

You can use this to turn the detailed team results .. 

 

.. into a short version with one line per team, still showing the last names of the athletes. 

 

How did we do this? 
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We use TS1.Px to access the three names of the athletes and show them in one line. Without any other 
modification the report would look like this: 

 

It would still show one line per participant. So we have to add the filter TS1.Position = 1. TS1.Position is the 
internal numbering of the team (1 => first team member, 2 => second team member, …), so the filter makes 
sure that only one record per team will be shown. 

7.6. Team Lap Race: Additional Fields 

When using a team score with lap mode (see chapter 3.10) for example for a 24h mountain bike race, you may 
need information about the participant who did the 25th lap of the team. For this you can use TSx.Ly.., For 
example 

 TS1.L25.Lastname 

returns the last name for the athlete that did the 25th lap of the team according to team score 1. After TS1.L25. 
any field can be used. 

7.7. Team Gap Times 

For team scores, there is no function like GapTimeTop, so we have to calculate gap times manually. Therefore 
the fields 

 TSx.DecimalTimeTopY and TSx.DecimalTimePrevY 

can be used which return the yth team time of the first team / previous team according to team score X. A 
possible expression for the team gap time would thus be: 

 iif([TS1.Rank]=1; "-"; format([TS1.DecimalTime1]-[TS1.DecimalTimeTop1]; "+mm:ss")) 

7.8. Aggregation Functions 

First of all note that the following aggregation functions are not very fast and should be used rarely. 

Assume you would like to show the number of finishers on a race certificate. For this you can use the DCount() 
functions which has a filter as first and only parameter: 

 DCount("[Finished]")  

If you would like to show the number of finishers that have the same first name you can use this expression: 

 DCount("[Finished] AND [FirstName]='" & [FirstName] & "'")  

Besides DCount, there are the functions DSum, DMin, DMax, DAvg that calculate the 
sum/minimum/maximum/average of a field, and DFirst that returns a field of the first participant fulfilling a 
expression. If you would like to show the average age of all finishers, you can use this expression: 
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 DAvg("[Age]"; "[Finished]") 

Why the double quotes around the field names? Because the parameter is the name (instead of the content) of 
the field that the function shall analyze! 
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8. FREQUENTLY ASKED ADVANCED QUESTIONS 
How to overwrite a formula result manually? 
The answer is: you can’t. But you can create a result for the manual time. Assume your formula result is result 
11. Change the ID to 21 and add another result “Manual Time” with ID 22. As result 11, you can create a 
formula result with formula 

 iif(T22>0; T22; T21) 

 

Speed or Time per km 
Make sure to enter the contest length in meters in Main Window -> Contests. Then you can use these 
expressions: 

 format(T1 / ([ContestLength]/1000); "mm:ss") & " min/km" 

 format(3.6*[ContestLength]/T1; "s.k") & " km/h" 

Relay numbers 
The bib number in race result has to be numerical. If you have relay numbers like 11-A, 11-B, 11-C, 12-A, 12-B, 
12-C, .. you can proceed as follows: 

 Use bib 111 for 11-A, 112 for 11-B, 113 for 11-C, 121 for 12-A, 122 for 12-B, and so on 
 Create a user defined field RelayBib (see chapter 4.4) using this expression: 

([Bib]\10) & "-" & choose([Bib]%10; "A"; "B"; "C") 
 Use RelayBib instead of Bib on all lists  / certificates. 

Team Score with Automatic Male/Female/Coed Detection 
Teams can be male, female or coed. These three categories will be scored separately, i.e. there is a first place 
for the male teams, a first place for the female teams and a first place for the coed teams. The field TSx.Sex 
automatically determines if the team is male (TSx.Sex=1), female (TSx.Sex=2) or coed (TSx.Sex=3). 

This field can then be used to group the team score: 

 
You can group your team results report for example by this expression: 

 choose([TS1.Sex]; "Male Teams"; "Female Teams"; "Coed Teams") 


